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With hyperCAD®-S, OPEN MIND has developed its own CAD system that is perfectly suited
to hyperMILL® and is designed to fully meet the requirements of CAM users. Whether
users are working with meshes, faces or solids to create precise components and tools –
hyperCAD®-S always provides the right answer.

Version 2022.2 is marked by customer requests for better usability of the software. It
includes many enhancements to make everyday work easier. The new option to select
faces within a closed chain of curves and boundaries and the option to set a workplane
based on a hole face are particularly worth mentioning.

hyperCAD®-S is CAD for CAM!
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1. Release notes
The following information refers to the hyperCAD®-S software and further products based
on hyperCAD®-S such as hyperMILL® SHOP Viewer and hyperCAD®-S Viewer.

This cumulative update contains all previous cumulative updates for the software plus the
following enhancements and hotfixes:

Release 2022.2 SP4
The following issues have been resolved:

Updating recommended

• CAD interfaces
• JT-Open: In the settings, e.g. in File → Open, the default setting for the option Filter

entities → Tessellations has been changed (back). To  load the tessellation additionally,
switch on this option as of now.

Release 2022.2 SP3
The following issues have been resolved:

Updating recommended

• Curves → Blending: If the command is opened with a preselected element of type Rectan-
gle, a crash occurs. That has been corrected.

• CAD interfaces
• The versions of the CAD formats PTC Creo, Siemens NX, Autodesk® Inventor® and

parasolid have been updated.
• SOLIDWORKS: Certain files could not be imported. That has been corrected.
• Autodesk® Inventor®: In a part, the wrong color were assigned to faces. That has been

corrected.
• Parasolid: An incorrect conversion result for a file has been corrected.
• STEP: Wrong UV parameter curves on spherical faces have been corrected.

Release 2022.2 SP2
All CATIA V5 and CATIA V6-Import formats are available for V5-6 R2022.

The following issues have been resolved:

Updating is highly recommended

• CATIA V5 import: An issue fixed with the distribution of control points.
• Features → Linear slot:  The software crashes by deactivation of the option Multishell

solid . That has been corrected.

Updating recommended

• A licensing issue for third-party API applications within hyperCAD®-S has been solved.
• File → Options → Electrode options: In Reference, entering multiple characters in Separa-

tor in names caused the counter after the separator not to increment. This has now been
improved. Now the separator can consist of more than one character. For example, not
only a _ but also an abbreviation like elec_ is now possible.

• Edit → Rebuild parametric model: The last feature of the model (fillet) fails when the
model is rebuilt (and/or one of its dimensions is changed). That has been corrected.

Release 2022.2 SP1
The following issues have been resolved:
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• Tire → Set segment parameters: After creating a curve with the command Create or
update a segment group and then changing the value Segment angle with the com-
mand  Set segment parameters this curve was deleted. That was incorrect and has been
corrected.

• Electrodes → Export reports: During (AM) export, the MASTER electrode was undesirably
output even if only multiple virtual electrodes were selected.

• In hyperMILL®-Jobs selected curves were lost after saving and opening a document in
case the model consisted of imported STEP data. That was incorrect and has been
corrected.

Release 2022.2
4K resolution for monitors is supported.

The hyperMILL® VIRTUAL Machining Center software has been expanded to include the
commands under File → Options → Layout manager.

File

• Print: In Single view – in the section Print area, the section to be printed can also be
selected with two dots in the graphics area. In the dialogue, X1, Y1 | X2, Y2 has been
changed to P1 | P2, where P stands for point.

• Save as → PDF file: Workplanes can now also be output in 3D in a *.pdf file. Note that
only workplanes with a name are output.

Edit

• Break: A progress bar has been added to avoid giving the impression that the software
has crashed if the calculation takes longer.

Drafting

• Points on curve: In Inflections, the option to reverse the direction has been removed, as it
is not necessary.

Curves

• Offset: The ‘Copies’ option has been renamed to Multiple offset.

Shapes

• Linear sweep and Rotational: An extrusion for several contours is possible at once. This
is especially recommended for parametric modelling based on V-sketches.

Feature

• Linear protrusion, Linear slot, Rotational protrusion and Rotational slot: An extrusion for
several contours is possible at once. This is especially recommended for parametric
modelling based on V-sketches.

Workplane

• The ‘On hole’ command has been renamed to On axial face / hole.

hyperCAD-S Electrode

• Several icons and options have been optimised in the EDM converter software.
• ZK Alpha Moduli support: The output has been integrated into the EDM converter soft-

ware. The menu items in the Export reports command have been removed. Certa output
for Certa software as middlewear is no longer necessary.
Reports for the following eroding machine types can currently be converted in the EDM
converter software.
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Machine types from Supported program-
ming system

Version Note

+GF+ AC FORM HMI From 1.8.0 Build 1966 In development

Older versions can also be supported on re-
quest.

Exeron Exoprog 1.6.10 Without rotational electrodes

Exolution In development

With rotational electrodes

Makino EDCAM 2020 To use the EDCAM simulation, electrodes and
model must be output individually as *.stp
models in the EDCAM folder structure. The
electrode metadata is output by the EDM con-
verter. The output from the EDM converter can
also be processed without the 3D models.

OPS Ingersoll PowerSPARK Editor From 1.6.4.0

Multiprog All

SODIK On request

Zimmer & Kreim Alpha Moduli

hyperMILL

• Call the  VIRTUAL Tool Editor and the  OPEN MIND tool database in hyperMILL →
Run.
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2. CAD interfaces
The following CAD models can currently be imported and/or exported (depending on the
licence purchased):

Product File type Up to version Import Export

Technology up to 31 De-
cember 2019

Current technology

CATIA V4 *.model 4.2.4 4.2.5 x

*.exp 4.2.4 4.2.5 x

CATIA V5 *.CAT-
part

6R2018 (R28) V5-6 R2022 x

*.CAT-
product

6R2018 (R28) V5-6 R2022 x

*.CGR Not supported V5-6 R2022 x

CATIA V6 *.3dxml Not supported V5-6 R2022 x

PTC Creo Parametric *.prt

*.prt.*

6.0 F000 9 x

*.asm

*.asm.*

6.0 F000 9 x

*.neu Not supported 9 x

PTC Creo *.xpr 6.0 9 x

*.xas 6.0 9 x

Siemens NX *.prt NXCR Siemens NX 2206 (June
2022 major release)

x

SOLIDWORKS *.sldpr
t

2019 2022 x

*.sldas
m

2019 2022 x

Autodesk® Inventor® *.ipt

*.iam

2019 2023 x

Rhinoceros® *.3dm Not supported 4, 5, 6, 7 x
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Product File type Up to version Import Export

Technology up to 31 De-
cember 2019

Current technology

Solid Edge *.par

*.asm

*.pwd

*.psm

Not supported V19 - 20, ST - ST10, 2022 x

PRC (Product Repre-
sentation Compact)

*.prc Not supported All versions x

Parasolid *.x_t 31 34.1 x

*.x_b 31 34.1 x

JT-Open *.jt 10.2 10.6 x

IGES *.igs

*.iges

5.2, 5.3 5.1, 5.2, 5.3 x

5.3 5.3 x

STEP *.stp,
*.step

AP 203

AP 214

AP 242

AP 203 E1/E2a

AP 214b

AP 242c

x

AP 214 AP 214 x

AutoCAD *.dwg

*.dxf

2018 (AC1032) 2019 x

2013-2017 (AC1027) 2019 x

Point clouds *.pt,

*.asc

*.xyz

*.txt

No version No version x

*.pt x

Polygon mesh *.stl

*.stla

*.stlb

No version No version x x

3MF Reader

(3D Manufacturing
Format)

*.3mf Not supported 1.2.3 x

ACIS *.sat

*.sab

Not supported 2021 1.0 x
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Product File type Up to version Import Export

Technology up to 31 De-
cember 2019

Current technology

Wavefront OBJ *.obj Not supported All versions x
a(ISO 10303-203) "Configuration controlled 3D design of mechanical parts and assemblies"
b(ISO 10303-214) "Core data for automotive mechanical design processes"
c(ISO 10303-242) „Managed model-based 3D engineering“

New commands and troubleshooting
CATIA V5: Datum planes can be read in. To do this, switch on when opening in the Settings
in Filter entities.

SOLIDWORKS: Adopt all coordinate systems as workplanes. To do this, enable the Axis
systems property when opening in the Settings in Filter entities.
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3. Extract from the documentation
Information on new commands and additions, as an extract from the software documenta-
tion:

User interface

Start screen
In the ‘Homescreen’ start screen, current information on hyperMILL® and hyperCAD®-S is
offered in the news area. A document can be opened or a new document can be created –
as with Open and New. The most recently used documents are displayed.

The font size of the news text can be changed usingCTRL and the scroll wheel. The start
screen can be switched on and off using the keyboard shortcut ALT+h. Use + or x to show
or hide the news area. The news area is not displayed if there is no news in the selected
language or no access to the Internet is available. Press F5 to refresh the start screen.

Tabs

Info
In the case of warnings, the following commands can be called via the context menu – if
justified in terms of content. To do this, right-click the warning.

Isolate entities in model structure for this warning: On the Model tab, the search is filled in
so that only entities relating to this message are displayed.

Isolate entities in model structure for all warnings: On the Model tab, the search is filled in
so that the relevant entities of all messages are displayed.

Data interfaces
Direct interfaces

Options
To display the PMI, the ‘MyriadCAD’ font is required as the standard font in Windows. Install
the font as administrator for all users. The MyriadCAD.otf file is located in C:\Pro-
gram Files\OPEN MIND\hyperCAD-S\[Version]\bin\converters\cad inter-
faces\[Version]\resource\Font.

This font can be changed in the Options [9] option of the settings when opening via a
direct interface.

Table 1. Options for opening data via a direct interface

Property Description

Assembly
conver-
sion mode

Select parts: In a dialogue [9], select from a list which individual parts
are to be imported and which are not to be imported. Mark the individual
parts to be imported in the list.
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Property Description

PMI font Replace font: Assign a different font for product and manufacturing infor-
mation (PMI), for example, to fit text into its border if the standard ‘Myriad-
CAD’ font proves to be too wide.

Font: Select a font.

Select individual parts for assembly conversion method
Filter the complete list of all individual parts. To do this, enter the components of the names
of the required individual parts as a character string.

Narrow down the result further using:

• Case sensitive: Take upper and lower case into account when filtering.
• Starts with: The character string should be at the beginning of the individual part name.

Limit the display using:

• Select / deselect all listed parts: Toggle the selection.
• Show selected only: Only lists the selected individual parts.

Select the filter result using:

• Select all filtered: All filtered individual parts are selected for import.
• Deselect all filtered: Removes all filtered, selected individual parts from the selection.

Close the dialogue using the X button in the dialogue title bar to accept the selected
individual parts and continue the process of importing them.

Select and snap
Select entities
From curves loop

Select entities within a closed chain of curves.

Select → From curves loop 2022.2

Select entities within a closed chain of curves. All inner entities are marked. The chain can
consist of 2D or 3D curves or boundaries. The viewing direction serves as a reference for
projecting the chain onto the entities.

Curves: Select a chain of curves along a given shape or outside (for example, ellipse) 1 .

Completely inside: The option allows you to decide whether the entities must lie completely
within the chain or may also overlap the chain. If the option is selected, only entities that lie
completely within are marked 2 .

Populate: Refresh the preview of the selected entities.
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2

Visible entities from curves loop

Select visible entities within a closed chain of curves.

Select → Visible entities from curves loop 2022.2

Select visible entities within a closed chain of curves. All visible inner entities are marked.
The chain can consist of 2D or 3D curves or boundaries. The viewing direction serves as a
reference for the visibility and projecting the chain onto the entities.

Curve: Select a chain of curves along a given shape or outside (for example, ellipse).

Completely inside: The option allows you to decide whether the entities must lie completely
within the chain or may also overlap the chain. If the option is selected, only entities that lie
completely within are marked.

Populate: Refresh the preview of the selected entities.

Workplane
Create workplane
On axial face / hole

Create a workplane on a hole.

Workplane → On axial face / hole

2022.1

Face
Face: Select a face of the hole.

Position: Select the position of the workplane at the upper (Start parameter) or lower edge
(End parameter) of the selected face.

Edit and modify
Edit
Spreadsheet

Manage and calculate variables.

Edit → Spreadsheet
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Import data

Update link
Update imported data of permanently linked Excel files.

A spreadsheet with an external link cannot be updated or changed if the
Excel file is open. Close the Excel file or release the Excel workbook for
collaboration. The Excel file must be opened via the share link. Only then
can collaboration take place during processing.

Points, curves and faces
Drafting
Points on curve

Generate one or more points on a curve, boundary or edge.

Drafting → Points on curve

Generate one or more points on a curve, boundary or edge.

NURBS data
Insert points at characteristic positions of a NURBS curve.

Spans: Create points at arc transitions.

Control points: Create points at the control point positions of the NURBS curve.

Cusps: Insert points at G0 positions.

Curves
Project

Project curves onto shapes or onto a plane.

Curves → Project

More options
Keep original: The initial curves are not removed.

Shapes
Offset

Create faces with an offset from existing faces.

Shapes → Offset

Multiple offset
Enter the number of Instances.
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Solids, features and meshes
Features

Pattern

Multiply existing CAD features or solids to form a determining pattern
and modify the pattern.

Features → Pattern

Solids

Select
Fast mode: Choose between a quickly generated pattern feature and a subsequently
changeable pattern feature:

• Static modelling: Do not use Fast mode if one of the copies or the base feature could be
disconnected, moved or redefined. Even if copies or the base feature itself is removed
from the pattern feature, the pattern feature can still be changed. Use Fast mode when
many copies are created within the pattern feature or when no changes need to be made
to the initially selected entity. The mode is faster, but a change would cause the pattern
to break.

• Parametric modelling: A pattern feature is always calculated in Fast mode. The option is
greyed out and inactive in the user interface.

NC programming
Print documentation

Output PDF

Table 2. Settings for saving a PDF document

Property Explanation

View size Create the output in the size of the current
graphics area (Yes). Otherwise in width
and height (No).

Width (pixel) and Height (pixel) Create the output in width and height in
the specified size.

Appendix
Information for administrators

GetHS.exe for start screen
The GetHS.exe software in C:\Program Files\OPEN MIND\hyperCAD-S\[ver-
sion]\bin\... downloads the news from the OPEN MIND server to the local workstation
to %PROGRAMDATA%\OPEN MIND\homescreen. To ensure the security of the content,
only pure HTML 2.0 code is loaded, without cascading style sheets or Javascript. The static
HTML code contains hyperlinks only to the official OPEN MIND website.

During installation, a ‘hyperCAD-S homescreen’ task is created in the Windows Task
Scheduler, with the help of which the software starts automatically every day and updates
the news area.
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Press F5 to refresh the start screen. The software can also be started manually for this
purpose. The task can be changed in the Windows Task Scheduler, for example, the time
of the update can be adjusted.

The checksum (SHA256) of the file GetHS.exe  is as follows:

64B7F2225CBFC2AEB0CD386DA8FAADC5231AC442BEF68C851201399BFAA72C7A

Environment variables

HC_HOMESCREEN_NEWS
Use the HC_HOMESCREEN_NEWS environment variable to switch off the news area of the
start screen by setting the value of the variable to 0.

HC_MAX_HOMESCREEN_ENTRIES
The maximum number of recently used documents is set to 20. This can be reduced using
the HC_MAX_HOMESCREEN_ENTRIES environment variable. Already saved, longer file lists
are shortened. The environment variable can be set to 0 to not display the most recently
used documents at all. The names of the most recently used documents are saved in the
registry.

HC_NEW_HOME_SCREEN
Switch the start screen on and off using the HC_NEW_HOME_SCREEN environment variable.
Set the value of the environment variable to 0 for switching off and 1 for switching on.

HC_HOMESCREEN_LOCALE
Change the language of the start screen using theHC_HOMESCREEN_LOCALE environment
variable.
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